Google Calendar Add-On
Incident Report for Callbridge
Resolved
This incident has been resolved.
Posted Jul 27, 2022 - 18:51 UTC
Identified
Google Calendar Add-On is not properly working. It is being caused by a bug Google introduced. Google has been notified and is aware of this situation.
Posted May 13, 2022 - 14:58 UTC
This incident affected: Feature.