Callbridge Conferencing Service Disruption

Incident Report for Callbridge

Resolved

This incident has been reslolved
Posted Sep 14, 2023 - 17:39 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 14, 2023 - 17:36 UTC

Identified

We are currently experiencing a disruption to our conferencing services.

Our team is diligently working to resolve this issue.

We will follow up with an email as soon as the service has been restored.
Posted Sep 14, 2023 - 17:33 UTC
This incident affected: Join Calls by Internet.