Callbridge service update
Incident Report for Callbridge
Resolved
Service is now fully restored as of 08/22/2023 10:50 UTC
Posted Aug 22, 2023 - 23:01 UTC
Identified
The web conferencing service is currently experiencing a higher than normal amount of load, and may be causing pages to be slow or unresponsive. We're investigating the cause and will provide an update as soon as possible.

Note that your telephone conferencing services have NOT been impacted in any way.
Posted Aug 22, 2023 - 21:13 UTC
This incident affected: Online Meeting Room and Mobile (iOS / Android) Apps.